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一、Cadence概述
作为流行的EDA工具之一，Cadence一直以来以其强大的功能受到广大EDA工程师的青睐。Cadence可以完成整个IC设计流程的各个方面，如电路图输入(Schematic Input)、电路仿真(Analog Simulation)、版图设计(Layout Design)、版图验证(Layout Verification)、寄生参数提取(Layout Parasitic Extraction)以及后仿真(Post Simulation)。如图1.1所示，我们给出了一个简单的模拟集成电路设计流程，以及对应的Cadence工具。
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图1.1  Cadence模拟电路设计流程
本文针对以上流程，通过设计一个简单的缓冲器的原理图到最终的版图，对Cadence的Composer，Analog Design Environment，Virtuoso，Assura等各大功能模块逐一做介绍。
    此外再介绍一点关于Cadence平台的知识。Cadence开发了自己的编程语言skill以及相应的编译器，整个Cadence可以理解为一个搭建在skill语言平台上的可执行文件集。初学者对此可以不用理会，当用户深入后，可以用skill语言对Cadence进行扩展。
二、运行Cadence

2.1建立个人工作目录

在登陆工作站后，于桌面空白处右键，tools->Terminal，打开终端。默认是在当前登陆的用户目录下，由于实验室机器是多人使用，为了不致混乱，需要建立自己的工作目录。在终端中输入
mkdir wavehorse                                                           
其中wavehorse为自己命名的目录名称，你可以用自己名字的拼音或者其它来作为工作目录名称。然后进入自己的工作目录
cd wavehorse                                                              
2.2启动Cadence之前的配置
Cadence初次启动之前需要如下一些配置文件：
.cshrc文件：有关一些Cadence必需的环境变量，如Cadence软件的路径及license。
.cdsenv文件：包含Cadence各种工具的一些初始设置。
cds.lib文件：用户库的管理文件，在第一次运行Cadence时会自动生成。
.cdsinit文件：包含Cadence的一些初始化设置以及快捷键设置。

实际上，机房中我们已将各配置文件写好，只要在终端中执行
cds.setup                                                                  
Cadence的相关配置文件就已经自动设置完毕。如果用户在启动Cadence后，发现无法使用快捷键，则需要把.cdsinit从Cadence的安装目录中拷贝到自己的工作目录下，在终端中输入：
cp /cad/cds/IC5141/tools/dfII/cdsuser/.cdsinit /home/bma/wavehorse        
请将其中的/home/bma/wavehorse换成自己的工作目录路径。
2.3拷贝相关的技术文件
在我们设计电路过程中，需要各种技术文件，这些技术文件一般是由Foundry提供。在本教程中，需要如下文件：
TF文件：TF(Technology File)文件一般由Foundry提供，包括了版图设计中的图层信息、符号化器件的定义以及一些针对Cadence工具的规则定义，还有版图转换成GDSII时所用到的层号的定义。本教程中需要的tf文件位于
/cad/smic018_tech/Design_Service_Technology/mixed-signal/LayoutTechnologyFile/SmicVTTF_LO_SRAM_MR_MM_HV_LC_018.tf
display.drf文件：控制Cadence的版图显示。本教程中用到的display.drf文件位于
/cad/smic018_tech/Design_Service_Technology/mixed-signal/LayoutTechnologyFile/display.drf
请将以上文件拷贝到自己的工作目录下。
2.4启动Cadence
现在，我们可以启动Cadence了。在终端中输入命令
icfb&                                                                    
出现Cadence初始界面，如图2.1所示。
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然后就会打开Cadence的主控窗口CIW(Command Interpreter Window)。如图2.2所示：
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这就是Cadence的集成设计环境，Cadence的大部分工具都可以从这里打开。其中最上方是标题栏，第二行是菜单栏。中间部分是输出区域，许多命令的结果在这里显示。一些出错信息也在这里显示，要学会从输出区域中获取相应的信息。接下来一行是命令输入行。Cadence的许多操作可以通过鼠标执行，也可以通过输入命令来执行。
此外还有一个What’new窗口，介绍Cadence新版本特性，不必理会，双击左上角将其关闭。

2.5建立个人工作库
Cadence是以库来组织文件的。为了使我们的工作和系统自带库区别，我们需要建立自己的工作库。有两种方法来建立新库，一是通过菜单栏Tools->Library Maneger打开库管理器，另一种是通过File->New->Library来建立新库。这里我们用第一种方法建立新库。单击菜单栏Tools->Library Maneger，会打开LM(Library Maneger)窗口，如图2.3所示。
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该窗口列出了当前已有的库。点击File->New->Library，打开New Library窗口，如图2.4所示。
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在Name一栏输入要新建的库名，如mylib，然后单击OK确定。出现Technology File设置窗口，如图2.5所示。如果不做版图设计的话，就不需要tf文件。这里我们选择第一项Compile a new techfile，单击OK确定。出现Load Technology File窗口，如图2.6所示。
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这里我们要输入tf文件所在路径，例如这里我输入的是
/cad/smic018_tech/Design_Service_Technology/mixed-signal/LayoutTechnologyFile/SmicVTTF_LO_SRAM_MR_MM_HV_LC_018.tf
确定后，就会建立名为mylib的新库，Cadence会在当前的工作目录下自动生成一个新目录mylib以存放和库mylib相关的文件。
三、电路图的输入——Composer
本章将通过画一个CMOS反相器来简单的介绍电路图设计流程。
3.1新建原理图
类似于新建一个库，有两种方法可以新建原理图，一是通过库管理器，另一种是通过CIW菜单新建。这里我们直接通过CIW来新建原理图。
在CIW窗口中，File->New->CellView，弹出新建对话框，如图3.1所示。

[image: image8]
于Library Name栏选择自己的工作库，如mylib，在Cell Name栏输入原理图名字，如interver，于Tool栏选择电路编辑工具Composer-Schematic，此时View Name栏自动变为schematic。最后单击OK。这样就会弹出Composer主界面。如图3.2所示。

[image: image9]
Composer主界面包括：标题栏，菜单栏，工具栏，状态栏(第二行)，提示区(就是最底下那行)以及最大的那个工作区。标题栏和菜单栏没什么好说的，状态栏会提示当前的命令以及所选择的物体个数，提示区会告诉你当前应该做什么事。作为初学者，在设计电路过程中应该要仔细阅读提示区中的信息。此外，
注意：①Composer中的多数命令会一直保持，直到你调用其它命令替代它或者按Esc取消，尤其是在执行delete命令时，忽视这一点很可能会误删除，一定要多加小心！Composer的Undo操作默认只能进行一次(可以在CIW窗口的Option->User Preferences中修改，最多可以是10)。所以每完成一个命令，记着按ESC取消当前命令。
②点击工具栏的zoomin和zoomout按钮可以放大缩小电路图。键入快捷键f可以使电路图自动缩放到合适大小。
③编辑电路图过程中注意要及时保存，保存方法是菜单栏->Design->Save，也可以键入快捷键大写的S(Shift+s)来保存。
3.2添加器件
现在，我们要开始画一个标准的CMOS反相器。一个反相器包括PMOS，NMOS，VDD，GND。
添加器件有三种方法，①菜单栏->Add->Instance，②键入快捷键i，③工具栏Instance，弹出的对话框如如图3.3所示。

[image: image10]
点击Browse，弹出库浏览器，如图3.4所示。选中Show Categories可以分类显示器件，方便我们快速找到所要的器件。

[image: image11]
依次点击analogLib->Actives->pmos4->symbol，再单击close。刚才的添加器件窗口发生变化，如图3.5所示。可以发现Library，Cell，View等都自动填上了相应的信息。同时多出了一些参数列表(拖动滚动条可以看到更多)。点击Hide隐藏当前窗口，此时鼠标对应有一个PMOS的symbol，此时按r键，可以旋转PMOS。移动PMOS到合适的位置点击鼠标左键将其放下。如果要放置更多的PMOS，继续点击鼠标左键，否则按ESC取消当前的放置器件命令。

[image: image12]
继续放置NMOS晶体管、电源与地。对应的器件名称为nmos4，vdd，gnd。放置完所有器件后的原理图如图3.6所示。注意，vdd与gnd仅仅是全局电源与地标识，并不是独立电源器件，vdd并不能提供电源。仿真时必须有gnd，否则仿真不收敛。

[image: image13]
3.3连线
现在要用导线把器件连起来。画导线的方法有三种，①菜单栏->Add->wire(narrow)，②键入快捷键w，③工具栏wire(narrow)。注意区别wire(narrow)与wire(wide)，wire(narrow)表示普通连接导线，而wire(wide)表示总线连接。总线连接的快捷键是大写的W。
进入连线命令后，于起点单击左键，再于终点单击左键。画完一段导线后，此时并没有退出画线命令，可以继续画连接线，直到画完所所有的连接线后，按ESC退出画线命令。连好线的电路图如图3.7所示。其中左右两条水平导线是后面连连接端口用的。
还可以对画好的线进行命名，键入快捷键l，在弹出的对话框中输入线名，比如a，点击Hide，然后将字母a移动到要命名的线附近点击左键放下，如果名字离线较远，则要求再单击所要命名的线。
3.4设置元件参数
现在需要设置元件参数，有三种方法，①菜单栏-> Edit-> Properties-> Objects，再点击要修改参数的元件，②先选中器件，再键入快捷键q，③选中器件，再点击工具栏Propertiy。
参数可以是以下三种形式的各种数学组合表达式，①变量，②常量，③skill语言函数。变量作参数会在仿真时用到。常量和skill语言函数作参数，在下面就会用到。
例如，单击PMOS选中它，这样PMOS会被一个白色方框包围。然后键入快捷键q，会弹出属性编辑对话框。这里我们需要填上model name，以及PMOS的栅长和栅宽。栅长我们设为常量0.18u(注意u是小写！)，而栅宽我们设为函数pPar(“wp”)，注意大小写不能错。当然也可以设一个固定的尺寸，但这样就不能利用参数修改晶体管的栅宽了。pPar函数就是把wp作为传递参数，在其它电路图中调用这个电路时对wp赋值，就相当于给这个PMOS的栅宽赋值，这样做的目的是为了方便层次化设计。在后面仿真时大家会更加明白这一点。Composer会根据数值大小自动变换单位。如图3.8所示。
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模型名我们填p18，这是因为我们这里采用的Spice模型是由SMIC提供的，对应PMOS的模型有p18和p33两种，18代表电源电压为1.8V。在后边仿真的时候我们还要再设SpiceModel文件的具体路径。如果需要查看其它模型名以及具体的模型参数，可以参阅如下文件，用任一文本编辑器打开即可。
/cad/smic018_tech/Process_technology/Mixed-Signal/SPICE_Model/ms018_v1p6_spe.mdl                                                                          
同样的方法继续设置NMOS参数，只是模型名为n18，栅长为固定值0.18u，栅宽设为pPar(“wn”)。设置好参数后的电路图如图3.9所示。
注意：①设置参数时不要自己输入单位，系统会自动加上。比如0.18uM是错误的写法。如果非要自己写单位，也要和数值之间留一个空格，否则系统会把M识别为变量。
②器件的参数也可以在放置时就设置好。
3.5放置端口
完成以上工作后，还必须放置I/O端口以标明电路的输入输出。放置端口有三种方法，①菜单栏->Add->Pin，②键入快捷键p，③点击工具栏Pin。
　　执行放置端口命令后，会弹出如图3.10所示对话框。于Pin Names栏输入端口名，比如Vin，于Direction栏选择input，点击Hide，然后将端口放到反相器的左边输入线上。同样的方法再放置输出端口，端口方向要改为output，名称为Vout，将其放在反相器右边的输入线上。最终的完成图如图3.11所示。

[image: image15]
3.6检查并存储
设计完成的电路图需要经过检查方能进行仿真。单击菜单栏->Check and Save或者键入快捷键大写的X，可以对电路进行检查并存储。
检查后如果有错会在CIW窗口上显示错误或警告信息。如果没错，则如图3.12所示：

[image: image16]
检查无误后可以关闭Composer了。
四、创建Symbol——Composer
现在我们要对上一章中画的反相器创建Symbol，这样做的目的是为了在更大的电路中用到我们前面所画的反相器时，可以用这个Symbol来代替。
4.1打开inverter原理图
CIW窗口菜单栏->Open，弹出打开对话框，选择自己的库，然后选择器件inverter，再于viewname栏选schematic，点击OK打开上一章画好的反相器原理图。
4.2创建Symbol
Composer窗口菜栏->Design->Create CellView->From Cellview，弹出Cellview from Cellview窗口，如图4.1所示。

[image: image17]
其中Library Name、Cell Name等栏已经自动填好，确认To View Name栏是symbol，点击OK。弹出创建Symbol选项窗口，如图4.2所示。

[image: image18]
这里已经自动识别出电路原理图中的输入输出端口，默认输入在左，输出在右，点击OK。显示出Symbol编辑窗口，如图4.3所示。

[image: image19]
默认生成的反相器Symbol是一个绿色矩形框，引脚按刚才编辑好的方式左右排列。红色矩形框代表调用这个模块时点选的区域，也就是说鼠标点到此区域范围内才可以选中这个Symbol。图中所有元素均可修改，但我们一般只改绿色矩形框。

4.3编辑Symbol并保存
默认的Symbol是一个比较大的矩形。对于反相器，我们习惯用一个三角形再加小圆圈来表示。
选中绿色矩形框，delete之，然后Add->-Shape>Polygon，在刚才矩形框的位置画一个三角形。鼠标在三个端点点3次即可。注意在三角形右边留出画圆圈的位置。
再Add->Shape->Circle，先于圆心位置单击左键，再移动鼠标，得到合适的圆的半径后左键确认。
再把图中的输入输出端口以及partname和instanceName移动到合适位置。其中，@instance Name代表以后调用此反相器时的编号，@partName代表对应的schematic的名字，一般不用改。最后再把红色框大小修改合适(框住三角形和端口)。
最终的symbol如图4.4所示。

[image: image20]
画好的Symbol需要检查保存。Design->check and save，检查结果显示在CIW窗口中。
五、电路仿真——ADE
现在我们用画好的反相器的symbol组成一个缓冲器(buffer)进行仿真，通过对buffer做瞬态分析、DC分析、AC分析，分别得到该buffer的延迟时间、输入输出特性以及小信号频率响应。
对电路进行仿真需要加激励信号，而加激励信号有两种方法，一种是在原理图中直接加入信号源元件，另一种是在仿真环境窗口(ADE)中对输入端口加激励。这里我们介绍的是第一种方法，第二种方法将在后续实验中介绍。
5.1创建缓冲器原理图和Symbol
缓冲器是由两个反相器组成，利用前边的方法，新建一个cellview，画出缓冲器原理图，如图5.1所示。

[image: image21]
其中反相器我们直接调用了上一章中画好的Symbol(注意是在自己的库中)。选中inverter，键入e，再点OK，可以显示和Symbol对应具体的schematic，但是这时只能看，而不能修改。Crtl+e退出该Symbol。
另外我们把缓冲器的输入输出两条线命名为IN和OUT，把第一级反相器的输出线命为V1。这样是为了在仿真时显示得更清楚。给连线命名的方法是：键入快捷键l，弹出连线命名窗口，于name栏输入线名，然后点击Hide，将名字移到要命名的线附近单击放下。

[image: image22]
设置inverter参数。选中inverter，键入q，就会弹出反相器的属性，如图5.3所示。这里我们需要分别设wn和wp的值。回忆3.4中给两个MOS管的栅宽设置传递参数，其实我们是给反相器的NMOS和PMOS的栅宽赋值。将Display设为both，可以在原理图上显示出参数值，当然你也可以不让其显示。

[image: image23]
回忆第四章内容，我们由缓冲器的原理图再生成Symbol。缓冲器的Symbol我们习惯用一个三角形来表示，如图5.4所示。

[image: image24]
5.2创建仿真电路
现在新建一个电路图，名为buffer_test，注意选为自己的库。画出测试电路，如图5.5所示。


[image: image25]
①独立电源vdc也是在analoglib库中，将其属性中的DC voltage设为1.8。
②另一个激励信号是方波源，对应器件名称为vpulse，也位于analoglib库中。方波源的属性设置如图5.6所示。方波上升下降时间为0.1n，周期为10n，脉冲宽度为4.9n，voltage1设为0，voltage2设为1.8。因为我们还要作AC分析，交流电压幅值为1(这样测得的输出直接就是小信号增益)。为了得到inverter的输入输出特性，我们把直流电压设为变量vin。

[image: image26]
对于初学者需要强调的一点，这里设置的方波电压、直流电压、交流电压是相互独立的，分别用于瞬态分析、dc分析、ac分析(但某些情况下是有联系的)。
5.3打开仿真环境
    Composer菜单栏->Tools->Analog Environment，打开仿真窗口(简称为ADE窗口)，如图5.7所示。其中比较重要的常用按钮已经标明。
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仿真时需要进行一些诸如仿真库文件路径、结果存储路径、仿真器选择等的设置，相关设置在setup中进行设置。这里我们只需要设置仿真库文件路径(仿真库文件记录着不同工艺角的参数，并指明了各元件类型的model文件所在路径)，其它均为默认设置。
于ADE窗口，Setup->Model Libraries，打开Model库设置窗口，如图5.8所示。单击“Browser”，打开浏览窗口，如图5.9所示，双击列表里的选项可以进入对应的目录，双击../可以进入上一级目录。我们所使用的model文件是由smic提供，其路径如下：
/cad/smic018_tech/Process_technology/Mixed-Signal/SPICE_Model/ms018_v1p6_spe.lib                                                                      

[image: image28]
选好后点击OK确认，然后再于Model库设置窗口的Section栏填写工艺角，这里我们填tt(即NMOS和PMOS速度均为典型值)，然后再点Add按钮，将当前的仿真库文件添加进列表，点击OK退出。
5.4设计变量
仿真环境菜单栏->Variables->Edit，或者直接点击右侧的工具栏中的Edit Variables按钮，弹出如图5.10所示窗口。击点按钮“Copy From”，就会列出我们前面在测试电路中添加的变量vin。选中该变量，我们设置一个初始值0.9。之所以是0.9，是因为当反相器的输入为0.9时两个MOS管都会导通，此时反相器实际起的是放大器的作用，而我们作AC分析就是要得到MOS管处于饱和区时它的频率响应。需要强调的是，AC分析是建立在一定的工作点上的，而电路的工作点正是由电路图中所设置的电源DC值以及这里的变量初始值决定的。

[image: image29]
5.5仿真设置
由于我们要做瞬态分析，dc分析，ac分析，所以我们一次弄好所有设置。
    ①Analyses->choose，或者点击右侧工具栏的choose analyses按钮。弹出如图5.11所示窗口。于Analysis栏选择不同的仿真。对于瞬态分析，我们选tran，然后于stop time栏输入仿真时间10n。

[image: image30]
②再于该窗口中选取dc，窗口会有相应变化。于sweep variable栏选择Design Variable，然后输入变量名vin，并输入变量的扫描范围，从0到1.8。并选择扫描类型为线性，扫描为0.001。这样仿真时就会对vin从0到1.8V以0.001为间隔进行扫描，从而得到输入输出特性。
注意选中DC Analysis复选框，这样就可以将AC分析时所采用的的直流工作点保存下来，以便我们后面查看电路的直流工作点。如图5.12所示。
③再于该窗口中选取ac，窗口会有相应变化。默认是频率扫描。我们只需要输入频率扫描范围。这里输入10到1000M(注意是大写)。其它均为默认值。如图5.13所示。

[image: image31]
5.6选择输出，并保存当前仿真设置
接下来要选择我们需要观察的对象，即我们要看哪个节点的电压，或者要看哪一条支路的电流。
于ADE窗口，Output->To Be Plotted->Select On Schematic，这样会弹出我们画的电路图。然后分别单击输入和输出两条线IN和OUT，以及第一级反相器的输出v1。注意选择v1时要先选中反相器，再按e进入下一层子电路。并注意一定要单击导线，而不是元件的Pin角！然后按ESC退出选择状态。此时在仿真窗口中已经有了IN、OUT、v1三项，如图5.13所示。

[image: image32]
保存当前的仿真设置。Session->Save State，弹出保存对话框，填好名称，点击OK确定。这样下次再仿真时，可以直接调用该仿真设置，而不用每次都进行同样的设置。
5.7进行仿真并查看波形
现在可以进行仿真了。于ADE窗口，Simulation->Run，或者点工具栏Netlist and run按钮，再点OK，就可以显示出前边所设置的output中指定的信号波形。如图5.14所示。

[image: image33]
默认是将所有仿真波形显示在同一个大窗口中，在上图中，从左到右分别是瞬态分析波形窗口、AC分析波形窗口、DC分析波形窗口。
图中每一个小窗口称为子窗口。子窗口右上角的数字图标若为绿色，表示当前子窗口处于被选中状态。对于选中的窗口，我们可以通过工具栏的按钮改变其显示方式，如将一个子窗口中的多条曲线分行显示等。工具栏各按钮作用如下：
[image: image34.png]


  将选中子窗口中的栅格打开或隐藏
[image: image35.png]


  将选中子窗口中的曲线分行显示。
[image: image36.png]


  将子窗口重叠排列，这样当前波形窗口内每次就只显示一个子窗口。
[image: image37.png]


  新建子窗口
[image: image38.png]


  新建波形窗口
我们也可以对波形进行操作。单击窗口中的曲线或者子窗口上方的信号名称，可以选中相应的波形。对于选中的波形，可以对其进行诸如删除、各种数学计算等操作，还可以对波形做任意的拖动操作，详细功能将在后面介绍。
5.8仿真结果分析
通过对仿真结果的分析，要学会波形测量、查看电路工作点状态、查看电路节点电压、查找器件参数、计算器的使用以及对波形窗口坐标等各种操作。

①瞬态结果分析。选中瞬态分析子窗口，点击工具栏按钮[image: image39.png]


，将瞬态波形放大到当前波形窗口中。为了看清缓冲器延时，需要放大波形的特定区域。在波形窗口中按住鼠标右键不放，拖出一个矩形框，框住瞬态波形中输出信号的上升部分，松开右键后，矩形框中的波形就会被放大到整个窗口。如图5.15所示。

[image: image40]
于波形窗口点击菜单栏Trace，然后将Horiz Cursor的对勾打上，此时会在当前窗口出现一条水平白线。拖动白线右边的红色头，可以上下移动白线，同时窗口上方会显示出水平白线与图中三条曲线交点的坐标值。我们拖动白线到纵坐标为0.9V的位置，然后就可以读出信号VIN、v1、VOUT对应的时间。比如这里分别为50ps、111ps、779ps，则第一级反相器的输出延时为61ps，总的缓冲器上升下降延时为729ps。同理我们也可以测出下降上升延时tPLH。

②AC结果分析。点击波形窗口右上角图标[image: image41.png]


中的数字，可以使相应窗口弹到最前面。点击数字2，则AC波形就到最前面。从图中我们可以大致读出缓冲器作放大器时小信号增益约为500，单位增益带宽接近1G。为了更精确的测量单位增益带宽以及3dB带宽，我们还要利用计算器得到输出信号的波特图及其相位频率响应。
由于带宽比较大，我们把AC分析的范围改大到10G，重新仿真一次。然后于波形窗口点击按钮[image: image42.png]


新建一个子窗口，再于菜单栏，Tools->Calculator，打开计算器，如图5.16所示。
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先点击Clear清除当前选中的信号。然后于信号选择区选中ac中的vf，这时会弹出原理图，从原理图中点击OUT线，此时会在表达式输入区出现VF(“/OUT”)，然后再于函数区单击dB20，输入区变为dB20(VF(“/OUT”))。再点击plot按钮[image: image44.png]


，就会在当前选中的波形窗口中显示出输出信号的波特图。此时波形窗口如图5.17所示。

[image: image45]
同样的方法再添加phase(VF(“/Vout”))，然后将该子窗口放大到波形窗口中，并点击分行显示按钮，如图5.18所示。利用Trace工具，我们可以精确地量出小信号单位增益带宽为1.2GHz。
另外，双击窗口坐标，弹出一个坐标属性窗口，可以调整坐标和栅格的范围、刻度等。例如对于相位频率响应的坐标，我们可以通过调整让其显示出90°、180°等我们希望的刻度。这里我们不再详述，同学们自己试验。

[image: image46]
③DC分析结果。将DC波形放大到当前窗口中，放大0.9V附近的波形。可以从中测出开关阈值电压VM。如图5.19所示。

[image: image47]
从DC分析结果中也可以看出，缓冲器比单级反相器具有更大的噪声容限。
此外，我们还可以得到AC分析中电路的工作点状态。于ADE窗口点击Results->Print，下拉菜单中有DC Node Voltages，DC operating Points，Model Parameters，Transident Node Voltages，Transident Operaing Points等选项，可以分别打印出电路的节点电压、工作点状态、模型参数、瞬态节点电压、瞬态工作点状态，如图5.20所示。
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同学们可以测试各种宽长比下电路的瞬态、AC、DC波形，分析第一级反相器和第二级反相器分别对电路性能有什么影响，并思考为什么。另外考虑该缓冲器既然有放大作用，能否用来作放大器，为什么。
对于电路仿真我们就只进行一个简单的介绍，更多的功能将在后续实验中介绍。
六、版图设计——Virtuoso Layout Editing
现在开始根据我们前边的设计尺寸，来画缓冲器的版图。为了显示层次化设计，我们先分别画出两个不同尺寸的反相器版图，再将两个反相器组成缓冲器的版图。
通常的版图设计步骤大概如下：①NMOS：画出N有源区->栅->做接触孔->覆盖金属->N注入区；②PMOS：画出P有源区->栅->做接触孔->覆盖金属-> N注入区；③连接晶体管：放置PMOS和NMOS->连接输出->连接输入->金属连接->电源线；④PAD。
由于反相器较为简单，我们直接开始画它的版图。
6.1新建layout

类似新建原理图，CIW窗口菜单栏->File->New->CellView，选择自己的库，然后输入版图名字inverter，注意于tool栏选择Virtuoso，ViewName栏会自动变为layout。点击OK后，会弹出Virtuso主界面，以及LSW窗口。如图6.1所示。

[image: image49]
图6.1(a)中的窗口是用来选择掩膜层的，我们可以在设计时随时改变层，在LSW中选中相应层，那么在Virtuso中就使用此层画图。(b)就是我们画版图的主窗口，结构类似Composer。
Virtuso主界面包括：标题栏，菜单栏，工具栏，状态栏(第二行)，提示区(就是最底下那行)以及最大的那个工作区。状态栏会提示当前的命令以及所选择的物体个数，提示区会告诉你当前应该做什么事。
注意：①类似Composer，Virtuso中的多数命令会一直保持，直到你调用其它命令替代它或者按Esc取消，尤其是在执行delete命令时，忽视这一点很可能会误删除！
②点击工具栏的zoomin和zoomout按钮可以放大缩小版图。键入快捷键f可以使版图自动缩放到合适大小。
③编辑版图过程中注意要及时保存，保存方法是菜单栏->Design->Save，也可以键入快捷键S(大写)来保存。
6.2参阅设计规则手册
版图有非常多的物理规则约束，这是由Foundry的工艺决定的。我们所使用的SMIC的0.18um工艺的设计手册在如下路径：
/cad/smic018_tech/Process_technology/Mixed-Signal/Design_Rule>TD-MM18-DR-2001v6P.pdf                                                                            
手册中每一条规则都给出了编号，比如AA.5，SN.01等。同学们在设计版图的过程中要时刻注意设计规则手册。在后面做设计规则验证(DRC)遇到错误时还要不断的回来查阅该设计手册。
6.3设置LSW窗口可见层
SMIC的工艺库默认有非常多的掩膜层。我们画反相器只需要其中一小部分层，为了方便我们操作，我们需要对LSW进行设置。LSW窗口->Eidt->Set Valid Layers，会弹出如图6.2所示窗口。表6-1给出了smic工艺中的关键层，并标出了我们在画反相器时所需要的层。请根据表6-1设置可见层。点击OK确定后，LSW窗口->Eidt->Save，弹出保存对话框，点击OK保存当前设置，这样下次再进入Virtuso时就会使用该设置。

[image: image50]
表6-1 SMIC关键掩膜层
	序号
	层名字
	含义
	含义
	本实验所需要的

	1
	AA
	Active Area
	有源区
	√

	2
	AR
	Reverse Active Area
	无源区
	

	3
	KV
	Alignment mark clear-out
	对准标记
	

	4
	NW
	N-Well
	N阱
	√

	5
	PW
	P-Well
	P阱
	

	6
	DG
	Dual Gate(thick oxide)
	双栅(厚氧)
	

	7
	GT
	Poly gate
	多晶硅
	√

	8
	PLH
	PMOS LDD implant for 3.3V
	3.3V下PMOS轻掺杂注入
	

	9
	NLH
	NMOS LDD implant for 3.3V
	3.3V下NMOS轻掺杂注入
	

	10
	PLL
	PMOS LDD implant for 1.8V
	1.8V下PMOS轻掺杂注入
	

	11
	NLL
	NMOS LDD implant for 1.8V
	1.8V下NMOS轻掺杂注入
	

	12
	SP
	P+implant
	P注入
	√

	13
	SN
	N+ implant
	N注入
	√

	14
	ESD1
	ESD implant for Boron(B)
	静电放电注入
	

	15
	SAB
	Salicide block area
	硅化物阻挡区
	

	16
	CT
	Contact
	有效接触孔
	√

	17
	M1
	Metal-1
	第一层金属
	√

	18
	V1
	VIA-1
	通孔1
	√

	19
	M2
	Metal-2
	第二层金属
	√

	20
	V2
	VIA-2
	通孔2
	

	21
	M3
	Metal-3
	第三层金属
	

	22
	V3
	VIA-3
	通孔3
	

	23
	M4
	Metal-4
	第四层金属
	

	24
	V4
	VIA-4
	通孔4
	

	25
	M5
	Metal-5
	第五层金属
	

	26
	V5
	VIA-5
	通孔5
	

	27
	M6
	Metal-6
	第六层金属
	

	28
	PA
	Passivation/Pad
	焊盘
	

	29
	PI
	Polyimide
	
	


注意除了表6.1中我们标出的需要显示的图层外，还需要M1TXT和M2TXT两层，用来标记输入输出。
6.3画第一个反相器
6.3.1画第一个晶体管——NMOS
一个标准CMOS反相器有两个晶体管，现在我们来画第一个晶体管NMOS，其栅长为0.18um，栅宽为0.6um。
①由于我们采用的是0.18um工艺，而在Virtuoso中默认最小单位为0.1um，因此我们需要改变该设置。Virtuoso菜单栏->Options->Display，会弹出显示选项窗口，将其中的X snap Spacing和Y snap Spacing两栏设为0.01，点击Save to保存，然后点击OK确定。
②画有源区。先选择标尺工具(Window->Create Ruler或者直接键入快捷键k)进行定位。点击左键开始，再点一次左键结束画标尺。用标尺定位一个1.42um×0.6um的矩形。点击ESC退出标尺命令。然后于LSW窗口中选择AA层。再于Virtuoso窗口->Create->Rectangle或直接键入快捷键r，沿刚才的标尺，画一个1.42um×0.6um的矩形有源区。如图6.3所示。

[image: image51]
③画多晶硅栅。键入快捷键大写的K清除当前所有标尺。然后利用标尺，于有源区中间定位好栅的位置。再于LSW窗口中选择GT层，然后再在Virtuoso中沿标尺画栅。如图6.4所示，注意由设计规则GT.5知多晶硅栅相对有源区的最小延伸为0.22um。

[image: image52]
④画接触孔。同上面的方法，于MOS管的漏区和源区各画一个有效接触。有效接触孔的图层名为CT。注意，画好一个有效接触后，另一个可以直接复制过去。方法为：键入快捷键c，然后选中要复制的对象，再移动对象到合适位置，点击左键放下。在放下对象之前按F3可以进一步选择细节，比如复制的物体以何种方式移动(水平、垂直、45度角等)。画好CT后如图6.5所示。注意由设计规则CT.1知接触孔的大小必须为0.22um。

[image: image53]
⑤画金属层。有效接触只是在氧化层上打了个孔，实际的连接得靠金属层。在LSW中选中M1层，然后以CT为基准外延0.16um画矩形。另一个M1矩形可以直接复制过去。

[image: image54]
⑥画扩散区。有源区仅仅是把芯片分为有源区和场氧区两部分。具体的有源区究竟是用来做PMOS还是做NMOS就是由扩散区类型来决定的。在LSW中选中SN，然后以有源区为基准，水平方向外延0.2um，垂直方向外延0.35um画矩形。

[image: image55]
至此，第一个晶体管NMOS我们就画好了。
6.3.2画第二个晶体管——PMOS

现在我们画第二个晶体管——PMOS。根据前边设计要求，L为0.18um，W为1.95um。我们在NMOS旁边的空白处开始画PMOS。前几步和NMOS差不多，只是在画接触孔时，由于P管较长，因此需要打多个孔，这样才能使得电流均匀地流过沟道，注意孔间距要大于0.25um。注意要用金属层M1分别包住源区和漏区各自的三个接触孔。
此外，我们的工艺是P衬底，对于PMOS我们还需要画N阱。以PMOS的有源区AA外延0.5um画N阱(图层名为NW)。画好的PMOS见图6.8。

[image: image56]
6.3.4信号线的连接
现在我们要把NMOS和PMOS连接起来，使其组成CMOS反相器。
①把PMOS移动到合适位置。用鼠标拖一个框，选中整个PMOS，键入快捷键m，然后点击PMOS，按F3改变snam mode到anyangle，点击hide，这时移动PMOS到NMOS上方，使P管和N管的栅在同一直线上。点击左键放下。如图6.9所示。

[image: image57]
②连接输出。在NMOS和PMOS的漏极之间画一个金属矩形，把NMOS和PMOS漏区的两块金属连接起来。然后再加上一块水平的金属。
③给输出加上标记。于LSW窗口选择M1TXT层，利用Create->Label(或者直接键入快捷键l)，于Label栏输入Vout，把Height改变为0.2，点击Hide，将标记放在水平的金属上。
④连接输入。在NMOS和PMOS多晶硅栅之间再画一个GT层矩形，把NMOS和PMOS的栅极连接起来。然后再加上一块水平的GT。栅必须还得和金属层连起来才能够连到外部输入。用CT连接一层金属到刚才的水平GT上。
⑤给输入加上标记。同上面的方法，给输入金属加上标记Vin。
到这一步的版图如图6.10所示。
6.3.4连接电源与地
现在来画电源线和地线。电源线和地线使用金属2。
①画电源线。于LSW窗口选择M2，然后在PMOS上方画水平矩形。
②连接电源线与PMOS源区。在PMOS源区上方用M1画矩形，使其一端连接PMOS源区金属，另一端和刚才画的电源线交叠。现在要把这两层交叠的金属连起来，金属1与金属2的连接是利用通孔1(图层名为V1)。于LSW窗口选择V1，在M1与M2交叠的地方画一矩形。由设计规则V1.1知通孔边长等于0.26um。
③给电源线加上标记。于LSW窗口选择M2TXT，然后给电源线加上标记vdd!。注意加上叹号的意思是该节点为全局节点。
④同样的方法用M2画出地线，并用V1将其和NMOS源区金属相连，然后用M2TXT加上标记gnd!。
到这一步的版图如图6.11所示。

[image: image58]
6.3.5做衬底接触
晶体管所在的衬底要有正确的偏置，NMOS的衬底必须接地，而PMOS的衬底必须接电路中的最高电位，即电源。给衬底加偏置的方法是作衬底接触。在P衬底工艺下，对于NMOS，就直接在P衬底上加P注入形成欧姆接触，并与地相连，对于PMOS，是在N阱上加N注入形成欧姆接触，并与电源相连。
①做P衬底接触。在NMOS旁边画AA矩形，然后用SP将其包围，再用接触孔CT和金属M1将该衬底接触与地相连。注意留够SP与AA间距。
②做N阱接触。注意先将N阱扩大，以便能放下欧姆接触。Edit->Stretch或者键入快捷键s，然后将鼠标移动到N阱的边线上，点击左键，这时移动鼠标就可改变N阱大小，再次点击左键确定。然后类似上面的方法做N阱接触，只是将SP换成SN，然后再用CT和M1将接触与电源相连。注意由设计规则SN.11，在靠近N阱边缘的地方，SN与AA的间距要大于0.18um。
图6.12即为第一个反相器最后画完的版图。注意这还不是最终的版图，只有通过了DRC和LVS的版图才能算是最终的版图。
6.4画第二个反相器
同样的方法，我们新建一个cellview，画第二个反相器的版图。注意根据前边的设计要求，第二个反相器的NMOS栅宽为1.8um，PMOS的栅宽为5.85um。为了使两个反相器在最后版图拼接时易于连线，同时也为了使MOS管的栅不要过长，我们利用叉指结构来做。图6.13显示了如何用叉指结构来形成栅长为5.85um的PMOS，清楚其间，我们没有画出P扩散区。

[image: image59]
实际上，叉指结构就相当于几个MOS管并联。图6.13中就相当于3个PMOS管的G、S、D分别相连。完整的第二个反相器的版图如图6.14所示。

[image: image60]
6.5画缓冲器版图
现在用前边画的两个不同尺寸的反相器来组成缓冲器。新建一个layout的cellview，名字取为buffer。
在Virtuoso界面中，键入快捷键i添加器件，点击browse，选择自己库中的反相器的layout，就会出现一个大的方框，代表inverter的版图，单击鼠标放在合适位置。同理再放置另一个反相器的版图。如图6.15所示。按Shift+f可以显示出下一级器件的版图细节。按Ctrl+f可以隐藏下一级器件的版图细节。

[image: image61]
按Shift+f显示出版图的内部结构，然后分别用M1和M2将两个反相器的输入输出以及电源和地连起来，然后用M1画输入与输出线。最后用M1TXT层给输入与输出加上标记IN和OUT，用M2TXT层给电源与地加上标记vdd!和gnd!。最终完整的缓冲器版图如图6.16所示。
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七、设计规则检查(DRC)——Assura DRC
Cadence用来做版图验证的工具有Diva，Dracula，Assura。Diva和Dracula已经处于淘汰的地位。因此这里我们简单介绍如何用Assura进行DRC、LVS以及寄生参数提取。
Assura具有完全的图形界面，并整合到Virtuoso的主界面中，是性能全面的版图验证工具，支持交互式和批处理操作，使用层次化的处理，能够快速、高效地识别和改正设计规则错误。
7.1运行Assura DRC
①首先我们在工作目录下新建一个目录DRC，用于存放DRC输出文件。
②打开上一章中我们画好的缓冲器版图，从Virtuoso菜单栏->Assuro->Run DRC可以打开Run Assura DRC界面，如图7.1所示。
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其中Layout Design Source设置版图文件来源，默认的是DFII格式版图，即标准的Cadence Design Framework II数据格式。你也可以选择Stream，即由GDS格式的版图来进行DRC。这里我们使用DFII。
使用DFII格式，则Library、Cell、View就会自动填好。于Run Name栏输入DRC输出结果名字，比如buf_drc，于Run Directory栏输入DRC输出结果路径，比如./DRC，则DRC输出结果将保存在当前工作目录下的DRC目录中。
③最重要的是规则文件的设置。我们所使用的SMIC的.drc规则文件位于如下路径：
/cad/smic018_tech/Design_Service_Technology/mixed-signal/DRC/SmicDRL2TM6P_asr018_mixlog_p2mx_mt.drc                                                   
可以直接将以上路径以及文件名输入，也可以点击“…”按钮来选择规则文件。
④由于反相器版图简单，只用到两层金属，而SMIC的设计规则默认要检查所有金属层以及多晶硅的覆盖率，简单起见，我们这里关掉覆盖率检查。在设置好规则文件后，就可以点击“Set Switches”按钮，弹出Set Switches窗口，选中NoDensityChecking，点击OK确定。
其它选项我们暂时先不管。以上设置完毕，可以点击“Save State”将当前设置保存，然后点击OK就开始运行DRC了。
7.2查找DRC错误并修改
点击OK运行DRC后，会先弹出一个Progress窗口，显示当前运行DRC的一些信息，当DRC结束后，该窗口就会消失，然后弹出是否查看当前DRC结果的对话框，点击Yes。
实际上如果严格按照上一章中提到的规则画反相器版图，将不会有任何DRC错误。这里给出一个故意加了些设计错误的例子以说明如何查找DRC错误，如图7.2所示。
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图7.2中的窗口简称为ELW窗口。ELW窗口左边列出了当前版图中的DRC错误类型，每一错误前中括号中的数字是错误个数，后边是错误编号以及解释。比如 

[3] SN.11: Min. enc 0.18um SN beyond an N+ pick-up AA if the distance between N+AA and N-Well < 0.43um
意思为编号为SN.11的DRC错误共有3个。该条设计规则的意思是：在距N阱边缘不到0.43um的情况下，SN相对AA区的最小包围为0.18um。根据编号我们可以查设计规则手册，以了解具体的错误信息。
ELW窗口右边列出的是违反对应设计规则的元件。因为我们这里只有一个元件反相器，所以所有的错误对应的只有inverter一个元件。选中相应的错误，再点击右方向键，可以在Virtuoso窗口中依次显示出对应的错误位置，并用相应的颜色标出。
依照提示修改所有的错误，然后再次进行DRC，直到没有DRC错误为止。注意每次重新进行DRC前要对修改的版图进行保存，并关掉当前运行的DRC(菜单栏Assura->Close Run)。
7.3一些高级DRC功能
7.3.1屏蔽器件
某些情况下在做DRC时，可能部分器件内部我们已经通过了DRC，在上一层电路中并不需要对其进行DRC了，为了加快速度我们可以屏蔽该器件。比如我们要跳过对缓冲器中第一个反相器的DRC。
①于Virtuoso窗口中，Assura-> Run DRC，弹出Run Assura DRC窗口。点击“Modify avParameters”按钮，弹出如图7.3所示的DRC参数设置窗口。
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②选中?ignoreCell，再选中Use in Run，然后于Cells栏中输入inverter1，如图7.4所示。点击OK确定。

[image: image66]
③此时Run Assura DRC窗口底部的View avParameters一栏中多出一行，如图7.5所示。点击OK确定，开始运行DRC。这样做DRC时就不会对inverter1的版图进行检查了。

[image: image67]
7.3.2屏蔽错误
有时候检测出的一些DRC错误我们并不想马上更正(或者出于其它原因)，我们可以把这些错误隐藏掉。
①在跑完DRC后，于ELW窗口中，File->Preferences，会弹出ELW Preferences窗口，选中其中的Add Commands during SingOff以及SingOff Feature然后点击OK确定。
②在ELW窗口中选中其中一项错误，并单击右方向按钮，会在Virtuoso中显示出当前的错误位置。
直接单击SingOff按钮，将会只屏蔽一个错误，在Virtuoso窗口中单击要屏蔽的错误位置，然后会弹出一个注释输入对话框，如图7.6所示。于Comment栏输入我们的注释(比如隐藏当前错误的原因)，然后点击OK确定。这样当前位置的指定类型错误就不再标出。
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我们也可以屏蔽选定区域内所有指定类型的错误。于ELW窗口中，Error Visibility->Sign Off Area，会弹出一个对话框，提示当前图层上被选中的错误标志将被隐藏，点击OK确认，然后于Virtuoso窗口中拖动鼠标画一个矩形，围住我们想隐藏错误标志的区域，又弹出一个注释输入对话框，输入我们的注释，然后确定。
这样我们选中的区域里指定类型的错误就不再被标注出来了。
于ELW窗口中，View->SingOff Errors，可以查看当前隐藏掉的错误。
7.3.3把屏蔽掉的错误作为DRC运行参数
在上次DRC中隐藏掉的错误，若不作其它设置，当再跑一次DRC时，这些错误又会出现。如果我们想一直隐藏这些错误，可以把隐藏掉的错误作为下次DRC时的参数。
①在隐藏掉一些错误后，于ELW窗口，File->Save As，会弹出保存对话框，将其中的SingOff Error File中的文件名改为：buf_waived.evd，然后点击OK保存。
②于Virtuoso窗口中，Assura->Close Run，关掉当前运行的DRC。
③于Virtuoso窗口中，Assura-> Run DRC，弹出Run Assura DRC窗口。点击“Modify avParameters”按钮，弹出如图7.3所示的DRC参数设置窗口。
④选中?exceptionFile，再选中Use in Run，然后点击“．．．”按钮，选择前边保存的buf_waived.evd文件(在DRC目录下)。点击OK确定。
⑤点击OK开始运行DRC。
从运行结果中可以看到，上一次隐藏掉的错误已经被忽略掉了，不再显示在ELW窗口中了。
八、版图和原理图一致性检查—Assura LVS
DRC完全没有错误以后，就可以进行版图和原理图一致性检测(LVS)了。
8.1 LVS前的准备
①生成原理图对应的网表文件。于CIW窗口，Export->CDL，弹出CDL Out窗口，点击“Library Browser”，选择自己的库以及反相器的原理图。然后于OutPut File栏输入网表文件名，比如inv_netlist.sp。再于Run Directory栏输入保存目录./LVS。注意一定要将Scale项选择为micron，否则在LVS时将会产生参数错误。如图8.1所示。点击OK将在LVS目录下生成相应的网表文件。
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②修改网表文件。用任一文本编辑器打开刚才生成的buf_netlist.sp文件，把NMOS和PMOS的模型名分别改为N与P，即将以下两行
MM1 Vout Vin gnd! gnd! NM W=wn L=180.00n

MM0 Vout Vin vdd! vdd! PM W=wp L=180.00n
修改为
MM1 Vout Vin gnd! gnd! N W=wn L=180.00n

MM0 Vout Vin vdd! vdd! P W=wp L=180.00n
关于为什么要这样改，将在后面说明。
③在自己的工作目录下新建一个目录LVS，用于存放LVS输出文件。
④用Assura作LVS需要四个文件：
extract.rul：版图提取规则文件
compare.rul：版图原理图比较规则文件
binding.rul：版图和原理图元件名字对应规则文件
smic18_lvs_include.rsf：LVS选项设置文件
以上四个文件均在SMIC的库目录下的smic18_lvs文件夹内，我们把整个smic18_lvs目录都拷到新建的LVS目录中(注意目录名字smic18_lvs不能改)，命令如下：
cp –r /cad/smic018_tech/Design_Service_Technology/mixed-signal/LVS/smic18
_lvs  /home/bma/wavehorse/LVS                                             
请将以上的/home/bma/wavehorse换成自己的工作目录。
此外还有一个assura_teach.lib文件，指定了以上LVS的库文件路径。把该文件也拷到刚才新建的LVS目录下。
cp /cad/smic018_tech/Design_Service_Technology/mixed-signal/LVS/assure_tec

h.lib /home/bma/wavehorse/LVS                                             
8.2 设置并运行Assura LVS
打开上一章中我们画好的缓冲器版图，先要指定assura_teach.lib文件的路径。于Virtuoso菜单栏，Assuro->Teachnology，弹出Teachnology Lib Select窗口，点击按钮“．．．”，选择我们前边拷贝过来的assura_teach.lib所在目录，或者直接输入如下的路径，点击OK确定。
/home/bma/wavehorse/LVS/assure_tech.lib                                        
于Virtuoso菜单栏，Assuro->RunLVS，可以打开Run Assura LVS界面，如图8.2所示。
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①Schematic Design Source设置原理图文件来源，默认的是DFII格式版图，即标准的Cadence Design Framework II数据格式。这里我们选择netlist格式，此时窗口会发生相应变化。点击“Add”按钮，选择我们前边生成的反相器的网表文件，并于Netlist Type栏选默认项CDL。然后于cell栏输入inverter。

②Layout Design Source设置版图文件来源，我们仍然使用DFII，则Library、Cell、View就会自动填好。
③于Run Name栏输入LVS输出结果名字，比如inv_lvs，于Run Directory栏输入LVS输出结果路径./LVS。
④于Technology栏选择smic18_lvs(如果前边没有指定assura_teach.lib文件，则不会有这一选择项)，于Rule Set栏选择Smic18_LVS_Bind，则下面四个规则文件会自动填好。如果选择undefined，则需要手动设置四个规则文件的路径。
点击Binding File栏后面的“View”按钮，可以看到Schematic和Layout元件名的对应关系，其中原理图的N和P分别对应着版图的n18和p18，由于我们的版图是采用0.18um工艺画的，所以Assura会把版图上的NMOS和PMOS提取为n18和p18的元件，然后再与原理图作比较，所以我们才会在前边需要对原理图的netlist文件进行修改。
设置好各个选项后如图8.3所示。
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其它选项我们暂时先不管。以上设置完毕，可以点击“Save State”将当前设置保存，然后点击OK就开始运行LVS了。
8.3 查找LVS错误并修改
点击OK运行LVS后，会先弹出一个Progress窗口，显示当前运行LVS的一些信息，当LVS结束后，该窗口就会消失，然后弹出是否查看当前LVS结果的对话框，点击Yes。

反相器较为简单，如果同学们一路顺利地做下来，到这里可能不会有任何LVS错误。这里给出一个故意加了些错误的例子以说明如何查找LVS错误，如图8.4所示。
LVS错误分为两类，一类是提取错误，诸如版图上的短路、开路、非法器件等。另一类是原理图与版图差异的错误，诸如线网、器件、端口以及参数等的不匹配。在LVS Debug窗口中可以分别查看这两类错误。
图8.4(a)中显示没有Extract错误，图(b)中显示出原理图与版图有1个线网、1个器件、2个端口不匹配。

[image: image72]
在图8.4(b)的窗口右边，选中不匹配的类型，再点击“Open Tool”按钮，可以分别打开对应的不匹配查找工具。比如选中Pins，再点“Open Tool”按钮，可以打开Pins Mismatch Tool窗口，如图8.5所示。

[image: image73]
从图8.5中可以看出，原理图上的Vin和Vout端口，在版图上没有与之对应的端口。点击Probe可以定位端口位置。在Assura Netlist窗口中，相应的端口会以高亮显示。如果对应的原理图被打开，那么原理图上对应的端口也会被高亮标出。
九、寄生参数提取(PE)——Assura RCX
运行完LVS后，就可以进行寄生参数提取了。Assura中进行寄生参数提取的工具称为RCX(Parasitic Resistance/Capacitance eXtractor)。注意，运行RCX前必须先运行LVS。
9.1 运行RCX前的准备
拷贝RCX所需文件到前边运行LVS时的库smic18_lvs目录下。命令如下
cp /cad/smic018_tech/Design_Service_Technology/mixed-signal/ParasiticExtrat
ion/SmicSP7R_018_mixed_assura_RCX/capgen_2m>* /home/bma/wavehorse/LVS/smic1
8_lvs
9.2 设置并运行RCX
运行完LVS后，于Virtuoso菜单栏，Assuro->Run RCX，可以打开Assura Parasitic Extraction Run界面，如图9.1所示。
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该界面包含6个标签页，分别进行不同方面的设置。
Setup：显示技术库名称和可用的Rels Set，设置输出格式等。
Extraction：设置需要提取的类型(如R、C、RC、RCLK等)，控制R、C、L、K提取典型值，选择提取范围(全芯片、指定的线网等)。
Filtering：寄生R、C、L、K元件过滤器。
Netlisting：输出类型中线网控制。
Run Details：指定运行名称，设置临时文件以及log文件路径等。
本次实验中的大部分选项都采用默认设置，我们需要设置的几项如下。
①Setup标签页。如图9.2所示。

[image: image75]
如果LVS运行正确，打开RCX后，Setup Dir一栏会自动填写为LVS的库目录。Output一栏选择寄生参数提取的输出格式，可以是Spice网表，Spectre网表，DFII格式文件等。这里我们选择Extracted View，则会在当前的buffeer单元下生成一个新的View(默认名为av_extracted)，对应的是一个从版图提取的包含了寄生元件的缓冲器电路。生成av_extracted view的好处是，可以直接通过Cadence的仿真环境对其进行仿真，并能直观的看到寄生元件等来源于版图的哪里。
②Extraction标签页。如图9.3所示。
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于Extraction Mode栏选择RC，即我们要提取的元件是电阻和电容。
Max fracture length栏设置电阻提取方式。默认为infinited，即每根连线被提取为一个电阻。如果输入具体数值，则每根连线被提取为若干电阻，电阻节点处提取一个等效电容。
Cap Extraction Mode栏设置电容提取方式。选择Decoupled方式，则所有的寄生电容均被等效提取为相对指定节点的电容。如果选择Coupled方式，则所有在两根连线之间的电容均被提取，同时衬底电容被等藕合到相对指定节点的电容。
于Ref Node栏输入参考节点，这里我们就输入gnd!。
设置完后注意保存当前设置，然后点击OK就开始运行RCX了。
运行过程中，点击Watch Log File，可以查看运行过程中的Log文件。RCX运行完后，会有对话框提示RCX运行成功。在Log文件的底部，显示出了RCX最终提取出的所有元件，如图9.4所示。
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9.3 查看RCX结果
于CIW窗口，File->Open，选择自己的库，Cell Name为buffer，View Name为av_extracted。点击OK按钮，则会打开刚才提取生成的缓冲器的av_extracted View，如图9.5所示。
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键入快捷键e，打开显示控制窗口，选中Use True BBox和Nets确定，并按shift+f，可以查看寄生元件的参数以及边线情况，如图9.7和图9.8所示。
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十、后仿真(PS)

提取完寄生参数，就可以作后仿真了。我们利用Cadence的层次化工具Hierarchy来管理我们的设计，方便我们对比寄生参数提取前后的仿真结果。
10.1 运行Hierarchy
于CIW窗口，File->New->Cell View，新建一个Cell View，选择自己的库，Tool一栏选择Hierarchy Editor，输入cell名buffer_test，点击OK确定，则会弹出如图10.1所示的对话框。
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点击Browse，弹出如图10.2所示的窗口，这里是要选择顶层cell，我们就选择前面已经画好的缓冲器仿真电路的schematic，点击OK确定。

[image: image83]
此时再于图10.1的New Configuration窗口中单击“Use Template”按钮，于新弹出的窗口中选择spectre，点击OK确定，则其它各项均自动填好。再点击OK确定。
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此时就会弹出Hierarchy Editor的主窗口，如图10.4所示。点击工具栏中的保存按钮保存当前设置。

[image: image85]
Cell Bindings栏中列出了当前顶层cell中buffer_test以及其所属cell中所有的元器件。点击工具栏中的按钮[image: image86.png]


，可以列出选中cell所属的所有器件，如图10.5所示，单元buffer中包含两个器件I0与I1，而这两个器件对应的cell是inverter1。

[image: image87]
点击工具栏中的按钮[image: image88.png]


，可以以树状结构显示器件。点击器件前面的箭头可以展开该器件下层的所有器件，如图10.6所示。
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10.2 对不带寄生参数的原理图进行仿真
在上边打开的树状列表中，右键单击I0(mylib buffer schematic)，Set Instance View->schematic，如图10.7所示。然后单击工具栏中的按钮[image: image90.png]


进行更新，于弹出的对话框中单击OK确定。

[image: image91]
再右键单击顶层cell，即(mylib buffer_test schematic)，点击Open，则会打开buffer_test的schematic，接下来就是对该不带寄生参数的原理图进行仿真，方法和前边第五章完全一样，仿真波形参考第五章中的图。
仿真完毕后不必关闭波形窗口以及仿真环境。
10.3 对带寄生参数的原理图进行仿真
同上面的方法，打开的树状列表中，右键单击I0(mylib buffer schematic)，Set Instance View->av_extracted，然后单击工具栏中的按钮[image: image92.png]


进行更新，于弹出的对话框中单击OK确定。此时，buffer_test中的元件缓冲器的view已经变成了带有寄生元件的av_extracted view了。
于刚才打开的仿真环境中，直接用前面设置好的仿真设置进行仿真，只是注意把仿真环境中Plotting mode选为New Win，如图10.8所示，这样是为了方便对比寄生参数提取前后的仿真波形。

[image: image93]
图10.9为考虑了寄生参数后的仿真波形。与提取寄生参数前的仿真波形相比，似乎最大的区别是缓冲器作放大器时的低频增益变小。实际上低频增益并没有这么显著的变化，而是由于寄生参数的影响，缓冲器的共模电平范围发生微小变化，而该缓冲器的输入共模电平范围极窄，因此增益发生显著变化。我们把仿真变量vin的初始值设为0.898V，然后再仿真一次，就可以看到增益又达到500以上。这也正是该缓冲器并不能用来作放大器的原因之一。

[image: image94]
对于缓冲器我们最关心的还是它的时序响应。在瞬态波形中，键入快捷键a，选中起始点，再次建入快捷键a，选中终点，系统会自动算出两点之间的X、Y坐标差值。利用这个我们可以很方便地测量时延。
寄生参数提取前后的电路仿真波形分别如图10.10和图10.11所示。可以看出，由于寄生参数的影响，缓冲器上升延时增加了23ps。
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